چاپ        ارسال به دوست

سوء استفاده‌ی متعدد از آسیب‌پذیری‌های روز صفرم در افزونه‌های وردپرس

‫وردپرس امروزه پرکاربردترین فناوری ساخت وب‌سایت در اینترنت است. طبق جدیدترین آمار، بیش از ۳۵٪ از کل وب‌سایت‌های اینترنتی، با نسخه‌های WordPress CMS (سیستم مدیریت محتوا) کار می‌کنند.

وردپرس به دلیل تعداد بسیار زیاد نصب فعال، می‌تواند هدف مناسبی برای حملات گسترده باشد. طی چند ماه گذشته، تلاش برای هک‌کردن سایت‌های وردپرس در مقایسه با سال گذشته، در سطح پایین‌تری قرار داشته است. دلیل این آرامش می‌تواند تعطیلات زمستانی باشد که اغلب منجر به کندشدن جهانی بدافزارها و فعالیت‌های هک می‌شود، زیرا هکرها نیز در این زمان در حال استراحت هستند.

اما در طول دو هفته‌ی گذشته، مجدداً حمله به سایت‌های وردپرس آغاز شده است. چندین شرکت امنیت سایبری متخصص در محصولات امنیتی وردپرس مانند Wordfence ، WebARX و NinTechNet، از تعداد حملات روزافزون به سایت‌های وردپرس گزارش داده‌اند.

تمام حملات جدید ماه گذشته، به جای سوءاستفاده از خود وردپرس، بیشتر بر سوءاستفاده از اشکالات در افزونه‌های وردپرس متمرکز شده‌اند.

در بسیاری از حملاتی که اخیراً اشکالات افزونه را ضبط کردند، هکرها در تلاش بودند که سایت‌ها را قبل از اینکه مدیر سایت فرصتی برای اعمال وصله‌های امنیتی پیدا کند، به سرقت ببرند. برخی از مهاجمان نیز اشکالات روز صفرم را کشف و شروع به کار کردند.

در زیر خلاصه‌ای از کلیه‌ی پویش‌های هک وردپرس که در ماه فوریه‌ی سال جاری اتفاق افتاده‌ و نقص افزونه‌های جدید وردپرس را هدف قرار داده‌اند، ارایه شده است:

• Duplicator

طبق یک گزارش Wordfence، از اواسط ماه فوریه، هکرها از یک اشکال در Duplicator سوءاستفاده کرده‌اند. این افزونه به مدیران سایت اجازه می‌دهد تا محتوای سایت‌های خود را صادر کنند.

این اشکال که در نسخه‌ی ۱.۳.۲۸ برطرف شده است، به مهاجمان اجازه می‌دهد تا یک نسخه از سایت را صادر کنند. این کار به آن‌ها اجازه می‌دهد تا اطلاعات پایگاه‌داده را استخراج کنند و سپس سرور زیرین MySQL یک سایت وردپرس را به‌سرقت ببرند.

• افزونه‌ی Profile Builder

یک نقص بزرگ در نسخه‌های رایگان و حرفه‌ای افزونه‌ی Profile Builder وجود دارد. این اشکال می‌تواند به هکرها اجازه دهد تا حساب‌های مدیریت غیرمجاز را در سایت‌های وردپرس ثبت کنند.

بیش از ۶۵۰۰۰ سایت (۵۰،۰۰۰ سایت با استفاده از نسخه‌ی رایگان و ۱۵،۰۰۰ سایت با استفاده از نسخه‌ی تجاری) در برابر این حملات آسیب‌پذیر هستند، مگر اینکه این افزونه را به آخرین نسخه به‌روزرسانی کنند.

• Themegrill Demo Importer

هکرهایی که از افزونه‌ی Profile Builder سوءاستفاده می‌کنند، می‌توانند یک اشکال را در ThemeGrill Demo Importer وارد کنند.

این افزونه در بیش از ۲۰۰،۰۰۰ سایت نصب شده است و این اشکال به هکرها امکان می‌دهد تا سایت‌هایی را که دارای نسخه‌ی آسیب‌پذیر هستند، پاک کنند و سپس در صورت رعایت برخی شرایط، حساب «مدیر» را به‌دست آورید.

به مدیران توصیه می‌شود این افزونه را به نسخه‌ی ۱.۶.۳ به‌روزرسانی کنند.

• افزونه‌های Themerex

هکرها از یک آسیب‌پذیری روز صفرم در این افزونه برای ایجاد حساب‌های کاربری مدیر در سایت‌های آسیب پذیر سوءاستفاده کردند.

با وجود حملات مداوم، وصله‌ای برای این آسیب‌پذیری در دسترس قرار نگرفت. به مدیران توصیه می‌شود که هرچه سریع‌تر این افزونه را از سایت‌های خود حذف کنند.

• Flexible Checkout Fields for WooCommerce

هکرها برای تزریق بارهای XSS که می‌توانند در داشبورد یک مدیر واردشده به سیستم ایجاد شوند، از یک آسیب‌پذیری روز صفرم که در حال حاضر برطرف شده است، استفاده کردند. بارهای XSS به هکرها این امکان را می‌دهند که حساب‌های مدیریتی را در سایت‌های آسیب‌پذیر ایجاد کنند.

به مدیران وب‌سایت توصیه می‌شود، همه‌ی افزونه‌های وردپرس ذکرشده در این گزارش را به‌روزرسانی کنند، زیرا احتمال سوءاستفاده از آن‌ها در طول سال ۲۰۲۰ و پس از آن، بسیار زیاد است.

منبع: https://cert.ir/news/12968


دسته‌ها: آسیب پذیری‌ها 


١١:٠٠ - دوشنبه ١٨ فروردين ١٣٩٩    /    شماره : ٢٥٣٦٢    /    تعداد نمایش : ٩٣



خروج